Sonictel Broadsoft Cisco | Limitations of Monitored Lines BLF and Recommended Firewall Configuration

Modified on Wed, Mar 6, 2019 at 5:40 PM

As one of the functions offered by the BroadSoft PBX service, Monitoring allows a station in the network to view the call state of other stations in the network. This feature is based on the BroadSoft Busy Lamp Field (BLF) service. See the Monitoring QRG for details https://broadcloud.broadsoft.com/php/cpbx/node/535


Conventionally, this application is found commonly used by executive assistants or front desk operators. The operators use an enhanced station type and a phone model that offers enough line keys to adequately monitor a large set of lines in the network.


Some models of Cisco, Polycom, and Yealink phones can support expansion modules to add additional keys to a device. Keys on an expansion module are typically configured for speed dial and allow the attendant to monitor a larger number of users. The maximum number of monitored or BLF lines supported on a VVX phone with Expansion Modules is 50. This is the limit on both the BroadSoft PBX call control platform and Polycom phones. The limit has to do with the maximum size of a UDP datagram. According to the TCP/IP specification, the maximum UDP datagram is 65507 bytes for pay load, the size can contain the information from up to 50 monitored phones with all the contact fields populated. However the maximum number of 50 BLF lines is not always guaranteed.


The actual number of BLF lines that are populated on the phone can vary depending on network conditions, the type of customer premise firewalls or NAT devices, and their configurations. A common issue that has been observed is the firewall or NAT traversing issue. Some firewalls will simply drop any fragmented packets while the others will drop packets when the number of fragmented packets exceeds a configured or default limit.

For example, the Cisco ASA 5500 firewall by default will drop a packet if the packet has been fragmented into more than 24 packets. When this happens, phones will not receive the BLF NOTIFY message (the BroadSoft PBX service uses SIP SUBSCRIBE and NOTIFY messages as defined in RFC 4235, RFC 4662 and RFC 3265). As a result phones can only display a certain number of BLF lines. In some cases, the BLF list may disappear on a phone when the number of BLF lines exceeds the limit defined on a customer premise firewall.


The recommended solution is to configure firewalls and/or NAT routers at customer premises to handle fragmented UDP packets. 


These firewall and NAT routers must be configured to support the maximum UDP payload size of 65507 bytes and to allow at least 45 fragmented packets per packet.


See the Limitations of Monitored Lines whitepaper for additional detail. https://broadcloud.broadsoft.com/php/cpbx/node/731


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article